你的joomla 1.5网站是否有升级到2.5版本的必要?

2012年1月,Joomla官方推出了Joomla 2.5版本。但大部分在运行的joomla网站都是Joomla  1.5版本,对于这些正常运行的网站,是否有升级的必要呢?下面我们就来就此进行讨论。

1、是升级,不是更新

这里讨论的是Joomla平台的升级,如Joomla 1.5升级至Joomla1.6;不并是指Joomla 1.5.24 更新到Joomla 1.5.35 这样的更新。

2、网站升级的出发点

Joomla 1.6或更高的版本无疑是比Joomla 1.5更优秀的(不然推出新版来干吗...),但它确实是你需要的吗?

  • 如果你的网站目前运行稳定,而且无需要增加特别的功能(只在新版支持的扩展),不建议进行升级。
  • 如果你的网站需要改版,需要一些特定的新扩展支持,而且已经考虑到改版、升级的成本,建议升级。

3、网站的升级成本

请参考Joomla官方文档中,介绍Joomla 1.5升级到Joomla 1.6的教程文章中,“升级之前”的介绍内容:

http://docs.joomla.org/Migrating_from_Joomla_1.5_to_Joomla_1.6#Before_Upgrading

文中讲述的是Joomla 1.5升级到Joomla 1.6,是大范围的升级,而不是简单的更新,与从Joomla 1.0升级到Joomla 1.5类似。这包括核心文件的更改、扩展的升级(需要确定你使用的扩展是否支持最新版的joomla)、数据库的改写、模板的重写、语言文件更新等工作。当然,还需要考虑你熟悉新系统的时间成本。

4、网站不升级,安全吗?

这世上没有绝对安全的程序,但如果有良好的安全意识和操作习惯,就可以放心。这方面我们可以先来看看Joomla  1.0,Joomla 1.0在2009年退出历史的舞台,但很多Joomla 1.0的网站并没有升级,例如著名的Joomla站点bestofjoomla.com使用的就是Joomla 1.0。我们在使用Joomla网站的时候,应该做好各种安全措施,或者安装第三方安全扩展,平时也要做好备份工作。Joomla 1.5 从2008年推出到现在,已经历尽了二十多个版本,修复了很多漏洞和bug,后面的版本主要是修复bug,可以说已经是非常安全了,当然,如果当官方不再支持更新而又爆出重大漏洞的时候,还是要升级,不过至少joomla 1.0还没有这种情况。

  • 作者:野草工作室
  • 发布日期:2012-01-30

文章评论功能仅对网站会员开放,请先 登录 注册

栏目公告

原野草工作室官网的博客栏目的文章,会逐步迁移至Joomla建站笔记栏目。

Joomla主机